Commit ca008679 authored by Alois SCHLOEGL's avatar Alois SCHLOEGL

get rid of warning 'MatplotlibDeprecationWarning: The mpl_toolkits.axes_grid...

get rid of warning 'MatplotlibDeprecationWarning: The mpl_toolkits.axes_grid module was deprecated in version 2.1. '
parent 665927db
......@@ -19,7 +19,10 @@ HAS_MPL = True
try:
import matplotlib
import matplotlib.pyplot as plt
from mpl_toolkits.axes_grid.axislines import Subplot
if (float(matplotlib.__version__[0:3]) > 2.1):
from mpl_toolkits.axisartist import Subplot
else:
from mpl_toolkits.axes_grid.axislines import Subplot
except ImportError as err:
HAS_MPL = False
MPL_ERR = err
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment